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1 INTRODUCTION 

1.1 OVERVIEW 
Congratulations on purchasing the Hell Moose Performance LLC VolSquirt M4.3/M4.4 ECU for all 94-98 

850, 98 S70 & V70 and 96-98 960 & S90 & V90. This ECU is based on Megasquirt 3 Pro which is a proven, 

well adopted and well supported aftermarket engine management solution. Our ECU uses a MS3-Pro 

Daughter board and a custom designed motherboard to adapt all OEM system functionality and make 

the system fully plug and play. The ECU uses the stock connector and case so that one doesn’t have to 

do extensive wiring modification (or design a completely new harness) in order to adapt the power of an 

aftermarket engine management system. 

1.1.1 Warning Labels 

Our system abides by the same warning labels as MS3-Pro. These can be found in the MS3-pro manual: 

“Everything comes with warning labels. Let’s get these out of the way. 

All parts are sold for OFF ROAD RACE-ONLY ground-vehicle use only, or vehicles that predate 

any federal and state emissions control requirements.  Aftermarket EFI/EMS systems are not for sale or 

use on pollution-controlled vehicles. Alteration of emission related components constitutes tampering 

under the US EPA guidelines and can lead to substantial fines and penalties. Your state/district may also 

have specific rules restricting your tampering with your vehicle’s emissions system.  In short, as stated 

before, our official policy has to be RACE or OFFROAD USE-ONLY in ground-based vehicles ONLY. 

Race parts are inherently dangerous and may cause injury or damage if improperly modified or 

altered before use.  DIYAutoTune.com [or Hell Moose Performance LLC] will not be held liable for and 

will not pay you for any injuries or damage caused by misuse, modification, redesign, or alternation of 

any of our products.  DIYAutoTune.com [or Hell Moose Performance LLC]  will  not  be  held  in  any  way  

responsible  for  any  incidental  or  consequential  damages  including direct or indirect labor,  towing,  

lodging,  garage,  repair,  medical,  or legal expense in anyway attributable to the use of any item in our 

catalog or to the delay or inconvenience caused by the necessity of replacing or repairing any such item” 

(MS3-Pro Manual). 

1.1.2 Technical Support 

Hell Moose Performance’s support team can be reached by emailing the following email address 

hellmooseperformance@gmail.com. Support is there to provide technical support on the system itself. 

Support is not there to provide tuning help or tuning advice. Tuning the system is up to the individual 

who has purchased the system. Whether this is tuning the system themselves or hiring someone. 

1.1.3 Copyrights 

This manual contains content copyright 2019 Matthew Micciolo and Hell Moose Performance LLC. Do 

not distribute any modified versions of this document. It may however be distributed or printed in its 

unaltered form. 

1.1.4 Disclaimer 

Hell Moose Performance LLC is not responsible for any damage you inflict to yourself or your car from 

misuse of this system. This includes (not limited to) not following instructions and or bad tuning. 

mailto:hellmooseperformance@gmail.com
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1.2 MS3-PRO BACKGROUND 
As stated in the overview this system is based on MS3-Pro. Before using this system, you are required to 

read the entire MS3-Pro manual. Everything up to section 6 can be skipped as this part has already 

been taken care of for you (PNP system and turn key tune file). The manual can be found here : 

https://www.diyautotune.com/downloads/ms3-pro/ms3pro_doc1.0.pdf  

1.3 WARRANTY 
Hell Moose Performance LLC provides both warranty for the Megasquirt 3 Pro Daughter board as well as 

the VolSquirt motherboard. Each of the individual warranties are described below. If a failure in the 

system in determined to be the Megasquirt board their 1-year warranty will apply. If it is outside this 1-

year warranty the board can be repaired by them for an additional fee. If the failure is determined to be 

the VolSquirt mother board it is also covered by a 1-year warranty. 

1.3.1 Megasquirt 3 Pro Daughter Board 

As quoted by AMP EFI: 

“Hoffmann Innovations, Inc. (“AMP EFI”) warrants to the original purchaser its entire line of AMP EFI 

MS3Pro engine control units, hereinafter referred to as “product(s)”, to be free from defects in 

workmanship and materials, under normal use and service, for the applicable warranty term.  All 

MS3Pro Engine Control Units carry a standard 1-year limited warranty from the date of purchase from a 

Hoffmann Innovations, Inc.  or Authorized Reseller. 3rd Party items sold by a Hoffmann Innovations, Inc. 

web property retain original manufacturer’s warranty.  Hoffmann Innovations, Inc. may, at its own 

discretion, repair or replace any product not operating as warranted with a similar or functionally 

equivalent product, during the applicable warranty term. Hoffmann Innovations, Inc. will make 

reasonable efforts to repair or replace any product returned under warranty within 30 days of receipt of 

the product.” 

1.3.2 VoLSquirt Motherboard 

Hell Moose Performance LLC warrants VolSquirt to the original purchaser and guarantees its products to 

be free from defects in workmanship and materials, under normal use and service, for the applicable 

warranty term. All VolSquirt motherboards carry a 1-year warranty. Hell Moose Performance LLC may, 

at its own discretion, repair or replace any product not operating as warranted with a similar or 

functionally equivalent product, during the applicable warranty term. 

1.4 RETURNS 
VolSquirt can be returned up to 30 days from the original purchase date. The item must be unopened 

and untampered with all accessories and its packaging in original condition. A 10% restocking fee will be 

charged for all returns. 

https://www.diyautotune.com/downloads/ms3-pro/ms3pro_doc1.0.pdf
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2 VOLSQUIRT M4.3/M4.4 HARDWARE 

2.1 OVERVIEW 
As stated earlier, this system is a plug n play (PNP) system designed to be fully compatible with all OEM 

features of the stock system (Motronic 4.3/4.4). 

Hardware Features: 

• MS3-Pro Daughter Board (full sequential injection, cop, etc.) 

• Retains stock M4.3/4.4 ECU Connector & Case & FULL OEM COMPATIBILITY 

• Compatible with Auto & Manual gearboxes 

• Onboard MCU with custom firmware and CAN interface to provide OEM features that MS3-Pro 

cannot run such as: 

o Drive Stock Tachometer 

o Drive Stock Coolant Temperature Gauge 

o Drive Stock Fuel Pump Relay 

o Drive Trip Computer 

o Drive Automatic Transmission Computer (except torque converter lockup) 

o Drive Check Engine Light 

o 10 Extra ADC Channels 

• 4 Bar onboard Map Sensor 

• 4 Bar onboard Barometric Pressure Sensor 

• Resistance based IAT input (recommended GM IAT Sensor – sold separately) 

• 0-5V Wideband Input (wideband not included) 

• Coil on plug or OEM distributor 

• Compatible with all OEM sensors & actuators (crank, cam, throttle, coolant, idle air, boost 

solenoid, etc.) 

• Main power relay control 

• Full Idle Air Control 

• AC Control with idle compensation 

• Knock Sensor Control with per cylinder detection and correction 

• Loads of safety features (AFR warn and cut, EGT warn and cut, over boost, oil pressure, etc.) 

• True Dual VVT Control (Using ME7 cam sensors) 

• Vehicle Speed Sensing front wheels (additional rear wheel input, requires external VR 

conditioner) 

• Staged injection (additional set of injectors for batch fire mode above certain load / rpm) 

• Flex fuel 

• Water Methanol Injection 

• 2 High current Outputs (5A) for use with solenoids such as VVT 

• 2 Medium current outputs (3A) for use with injectors such as staged injection 

• CAN network expandable for extra IO / digital dashboards or gauge clusters, individual AFR or 

EGT, etc. 

• USB-B Connection 
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2.2 WHAT’S INCLUDED? 
• VolSquirt ECU 

• 3M USB Cable 

• 15 Molex pre-crimped leads for Molex connectors 

• Molex 24 pin connector 

• Molex 12 pin connector 

2.3 WHAT NEEDS TO BE PURCHASED SEPARATELY… 
• Wideband kit with 0-5V analog output (recommended AEM X-Series) 

• IAT Sensor (recommended GM 25036751) 

3 INSTALLATION 

3.1 REMOVE OLD ECU 

3.1.1 Remove ECU Cooling Tube & Box Cover 

3.1.2 Unlatch and Pull Out Old ECU 

3.2 INSTALL NEW PNP ECU 
Follow the above procedure in reverse. 

3.3 CONNECT VACUUM/BOOST SOURCE 
Use the included 3mm vacuum line and plug the line into the vacuum nipple on the ECU. Run the line to 

an open vacuum port on the vacuum tree. Use cable ties or metal clamps to make sure the vacuum lines 

are secure. 
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3.4 WIRE UP WIDEBAND 
First disconnect your Front & Rear O2 sensors. This can be done by unplugging the sensor from the 

harness. 

For proper operation the ECU requires a wideband sensor input. This must be a 0-5V analog input. Most 

wideband controllers support this. 

It is highly recommended to use an AEM X-Series wideband such as AEM 30-0300. This wideband has 

been extensively tested with the system and provides the best results. 

The analog output of the wideband can be wired 2 different ways: 

1. To the stock front O2 plug 

2. To pin P9 (FO2) on the external 12-pin IO connector (see below) 

If the wideband has a signal ground (SGND) it should be wired to pin P2 on the 24-pin IO connector (see 

below). Do not ground the power ground of the wideband to the ECU. This will create noise on its 

internal ground planes. Ground it to a good engine ground or engine ground strap. 

 

3.5 WIRE UP IAT SENSOR 
First disconnect your ambient air temp sensor (1998) or EGR sensor (all others). 

Any resistance based IAT sensor can be used. We recommend GM 25036751 (can be purchased on our 

website – sold separately).  

There are multiple ways to wire in the IAT Sensor. 

The first is by using the external header on the ECU. Run one wire of the IAT sensor to SGND P2 (SGND) 

on the 24-pin IO connector and the other leg to the IAT input P10 (IAT) on the 12-pin IO connector (see 

below). 

Alternatively, you could also do the following: 

1. 94-97 (NO EGR) – Follow the method above 

2. 94-97 (EGR) – Cut off EGR plug and wire it to that 

3. 98 (Ambient Temp) – Cut off ambient temp sensor plug (blue down near bumper) and wire it to 

that. 
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3.6 TEST COMPUTER CONNECTIVITY 

3.6.1 Download and Install Tuner Studio 

The free version of Tuner Studio (Tuner Studio Lite Free) can be downloaded from this web page 

http://tunerstudio.com/index.php/downloads  

However, it is highly recommended to purchase at least Tuner Studio MS so you have access to features 

such as Autotune VE. 

https://www.efianalytics.com/register/register.jsp?appName=TunerStudioMS  

3.6.2 Open Base Tune Project 

Upon purchase you will receive an email with a link to the base tune. 

Extract the contents of the ZIP file to your desktop (or wherever you desire).  

Open Tuner Studio. Navigate to File -> Open Project. 

 

Navigate to the folder that you extracted earlier. The folder that you extracted will show up as a project 

file. Select it to open the project in Tuner Studio. 

http://tunerstudio.com/index.php/downloads
https://www.efianalytics.com/register/register.jsp?appName=TunerStudioMS
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3.6.3 Connect USB Cable & Power On Car to POS II 

Connect the included USB cable to the ECU and to your computer. Power on the car, but do not start it. 

 

You should see Tuner Studio connect to the ECU. If it prompts you about differences between your 

current tune and the ECU be sure to select “Send current tuner studio settings.” 

If it doesn’t automatically connect, go to Communications -> Settings. 

 

The following screen will pop up. Click Detect. 
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Now wait as Tuner Studio automatically searches for your ECU and select it when it does find it. 

 

3.7 CALIBRATE THE ECU 
Before starting the vehicle, you must calibrate your Throttle Position Sensor, Coolant Temperature 

Sensor, Intake Air Temperature Sensor and Wideband Sensor. 

3.7.1 Throttle Position Sensor 

Go to Tools -> Calibrate TPS. 



10 
 

 

With the throttle closed (foot off the gas pedal) press the “Get current” on the “Closed throttle ADC 

count.” 

With the throttle fully opened (gas pedal all the way down) press the “Get Current” on the “Full throttle 

ADC count.” 

Click Accept. 

 

3.7.2 Coolant Temperature Sensor 

Go to Tools -> Un/Lock calibrations to unlock the calibrations. Make sure to relock them when you are 

done. 
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Select unlocked. 

 

Go to Tools -> Calibrate Thermistor Tables. 

 

Enter in the following for the Coolant Temperature Sensor and then click “Write to Controller,” and then 

close. 
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3.7.3 Intake air Temperature Sensor 

Select “GM” from the Common Sensor Values if you are using GM 25036751. It should look like the 

following, then click “Write to controller,” then close. If you are using a sensor other than the GM 

sensor enter the appropriate configuration for that sensor. 
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3.7.4 Wideband Sensor 

Go to Tools -> Calibrate AFR Table. 

 

Select the wideband you are using from the drop down and click “Write to Controller,” and then close. 

 

Make sure to relock the calibrations when you are done. 

 

3.8 INJECTOR CALIBRATION 
The last step before starting the car for the first time is calibrating the injectors.  
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3.8.1 Required Fuel 

More information can be found in section 5.2 of the MS3 Pro manual. 

Navigate to Basic/Load Settings -> Engine and Sequential Settings. Click on the required fuel button. 

 

Set the parameters according to the engine and injectors that you have. Also set the air fuel ratio based 

upon the fuel you are using. If you are using gasoline use 14.7. If you are using E85 use 9.8.  

 

3.8.2 Dead Times 

More information can be found in section 6.3.1 of the MS3 Pro manual. 

To configured injector dead times, navigate to Fuel Settings -> Injector Dead-Time. Leave the following 

settings. 

 

Now modify the percent vs voltage. For example, if the dead time at 12.8V is 1.45ms. Divide 1.45ms by 

1.000ms and multiply by 100 = 145%. 
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3.9 START VEHICLE 
Start the vehicle. The vehicle should fire up. It may run a little rough when cold or in general as when 

using speed density, the VE fuel map must be tuned individually for each different car. This makes it 

hard to get a perfect base tune for everyone who purchases the system. However, this tune should get 

you idling and driving around. Get the car idling smoothly and perform the next step, checking ignition 

timing, before driving the car. 

Make sure to keep an eye on AFR and stay out of boost!! Hell Moose Performance LLC is not responsible 

for any damage you do due to your own negligence on this base tune or using this ECU in general. 

3.10 CHECK IGNITION TIMING 
This step is extremely critical. If your base timing is set wrong, you can run timing that is more advance 

than you think it is and consequently run into severe detonation which will destroy your engine. 

3.10.1 Set the engine to Volvo TDC (on the crank) 

Use the same Volvo timing marks that you would use when doing a timing belt job to set the crank to 

Volvo TDC (ignore the gold mark here it serves no purpose other than to help find Volvo TDC easier). 

 

3.10.2 Mark the cam wheel and cover 

Make a mark on the cam tooth and a mark on the timing cover. This can be done anywhere. Do this for 

both the intake and exhaust cam wheel. This is so if your mark on your intake is out of phase you can 

use the mark on your exhaust cam since its 180 degrees off and won’t have to set the crank to TDC again 

to make another mark. 
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3.10.3 Set fixed timing in Tuner Studio 

In Tuner Studio go to Ignition Settings -> Ignition Options/Wheel Decoder. Change fixed advance from 

“use table” to “fixed advance.” Set the “Timing for fixed advance (degrees)” to 15. 

 

Start the engine and with a timing light hooked up to cylinder 1 make sure the mark on the cam you 

made earlier lines up exactly. Its OK for it to be a ¼ of a tooth retarded or advance just make sure it is 

not a full tooth or more off. If it is off by a lot either your marks are incorrect, or you have a severe 

trigger issue. Stop what you are doing and contact Hell Moose Performance LLC. You are responsible 

for any damage you do to your engine because of improper setup / improper checking of ignition 

timing. 

Make sure to change “fixed advance” back to “use table” when you are done. 
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4 TUNING 

No tuning from Hell Moose Performance LLC is provided with this system other than the included base 

tune. You will either need to tune the system yourself or find someone to tune it for you. Megasquirt is 

a very widely used system and you should have no issues finding someone to tune it for you. 

Below are a few people Hell Moose Performance LLC recommends contacting if you are interested in 

remote tuning. 

Brett Willett – Willetrun Automotive 

Calvin Sonniksen – Sovvagn Motorwerke 

4.1 ENABLING COP 
Make sure that COP is wired as depicted in section 5.6. 

In you are using COP a setting in the base tune needs to be changed in order to enable. It. In Tuner 

Studio navigate to Ignition Settings -> Ignition Options/Wheel Decoder. Change Number of coils to 

“Coil on plug.” That’s all that has to be done! 

 

4.2 ENABLING VVT 
Make sure that VVT is wired as depicted in section 5.7. 

If you are using VVT the base tune comes with all the settings already preconfigured. If you are using 

dual VVT you simply have to enable it. All of the settings for it are preconfigured. In Tuner Studio 

navigate to Boost/VVT -> VVT Settings. Change No. VVTs from off to 2. 

 

If you are using single VVT intake simply set No. VVTs to 1. If you are using single exhaust VVT set No. 

VVTs to 1 and copy the settings from CAM2 to CAM1 but change Input to Main Cam and Int./Exh to 

Exhaust. 
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5 EXTERNAL IO 

5.1 OVERVIEW 

5.1.1 External IO connector schematic (looking at IO connectors face on) 

Below is a diagram if one were to be looking at the IO connectors straight on. 
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5.2 5V & 12V SUPPLY 
The ecu has both a 5V and 12V supply. They both are switched on ignition POSII. 

5V (P1 on the 24-pin connector) – DO NOT EXCEED 250mA of current!!! You will overload the onboard 

5V regulator. This is to be used to power external pressure transducers, temperature sensors or ME7 

cam sensors that draw very low current. Use P2 (SGND) on the 24-pin connector when using this circuit.  

12V (P23 on the 24-pin connector) – DO NOT USE THIS TO POWER HIGH CURRENT 12V CIRCUITS SUCH 

AS SOLENOIDS, WIDEBANDS, ETC. This is to be used for testing only or for supply lower power devices 

such as sensors or CAN modules. Use P24 (PGND) on the 24-pin connector when using this circuit. 

 

5.3 EXTRA ADC CHANNELS 
The system contains 10 extra 0-5V 10-bit ADC channels. These are labeled P3-P12 on the 24-pin 

connector to the left. Do note that if you are using AC control P3 (AIN2) is reserved for the AC Pressure 

sensor. If you don’t use AC control simply unplug the AC pressure sensor (3 pin plug near drivers 

passengers side headlight) and this channel can be used. If you are using AC control and unplug the 

pressure sensor and still run the AC you WILL FRY THE AC COMPRESSOR.  

5V supply for the sensors can be hooked up to P1 (R5V) on the 24-pin connector. You must use P2 

(SGND) for the sensor GND on the 24-pin connector. If you use P24 (PGND) on the 24-pin connector 

you will have a lot of noise on your sensor input. 

The 5V supply has a current limit of 250mA. DO NOT EXCEED THIS! 

These can be configured in Tuner Studio under Advance Engine -> Generic Sensor inputs. For further 

information on configuration look at section 7.8.3 in the MS3-Pro user manual. 

 



20 
 

5.4 EXTRA 5V DIGITAL INPUT 
The system contains 2 dedicated 5V digital IO P7 (DI2(5)) and P8 (DI3(5)) on the 12-pin connector. They 

correspond to Digital Switched in 2 and Digital Switched in 3 in MS3-Pro respectively. These can be used 

for switches and are configured in pull-up mode. Wire a switch, toggle, momentary press, etc. between 

these pins and ground. Turning the switch on will GND the input. These can be used to enable things 

such as 2-step, rolling anti-lag, etc. 

 

5.5 EXTRA 5V DIGITAL OUTPUT 
The ECU has one 5V digital output P19 (IGN7) on the 24-pin connector. This output is inverted. On – 0V 

and off – 5V. 

Do not exceed 200mA on this output! 

 

5.6 EXTRA HIGH CURRENT AND MEDIUM CURRENT OUTPUTS 
If VVT isn’t used P13 (VVT1) & P14(VVT2) on the 24-pin connector can be used to drive external 

solenoids up to 5A each. 

If staged injection isn’t used P16 (MC1) & P17 (MC2) on the 24-pin connector can be used to drive 

external solenoids up to 3A each. 
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5.7 COIL ON PLUG 
Coil on plug can be configured in multiple ways. You can either re-pin the stock ecu connector or build 

an external harness. 

5.7.1 Re-pin Stock ECU Connector 

Populate the ecu connector (female car side) with new pins (Volvo PN 978925) or pins salvaged pins 

from a spare connector as follows: 

Cylinder 1 – B11, Cylinder 2 – B10, Cylinder 3 – B14, Cylinder 4 – B34, Cylinder 5 – B13 

5.7.2 External Harness 

Populate the included Molex connector for the 12 pin connector. On the top row wire IGN1-5 (P1-P5) in 

the firing order 1-2-4-5-3. 

Cylinder 1 – IGN1, Cylinder 2 – IGN2, Cylinder 3 – IGN5, Cylinder 4 – IGN3, Cylinder 5 – IGN4 

 

5.8 VVT 
MS3-Pro supports full closed loop VVT control. In order to use this, you must be using a RN VVT head 

and also use the ME7 cam wheel and cam sensor. Please refer to section 7.6 of the MS3-Pro manual for 

more information on VVT control. 

Be sure to disconnect the front & rear o2 plugs as the VVT drivers are connected to the o2 heaters (for 

cross compatibility between M44 VVT mod). 
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5.8.1 ME7 Cam Sensor 

You must use the ME7 cam sensor from 99+ Volvo vehicles. Make sure to use the appropriate cam 

sensor wheel. The intake and exhaust wheel are different and labeled.  The ME7 cam sensor is 5V 

supply do not provide it with 12V like the stock 94-98 sensor. 

5.8.2 Single 

For single VVT, the ME7 Cam sensor must be fitted to whichever cam has variable control. In single VVT, 

the sensor must be wired up to the stock cam sensor plug.  

The VVT solenoids can be wired as follows.  

Intake only VVT: One end of the plug to 12V (use a fused location) and the other end to P13 (VVT1) on 

the 24-pin connector. 

Exhaust only VVT: One end of the plug to 12V (use a fused location) and the other end to P14 (VVT2) on 

the 24-pin connector. 

5.8.3 Dual 

For dual VVT, the ME7 cam sensor must be fitted to both cams. The intake cam must be wired to the 

stock cam sensor plug. The exhaust cam sensor must be wired to P15 (VVTCMP) on the 24-pin 

connector. 

The VVT solenoids can be wired as follows.  

Intake: One end of the plug to 12V (use a fused location) and the other end to P13 (VVT1) on the 24-pin 

connector. 

Exhaust: One end of the plug to 12V (use a fused location) and the other end to P14 (VVT2) on the 24-

pin connector. 

 

5.9 STAGED INJECTION 
An additional bank of injectors can be added for staged injection. Wire injectors 1, 2 and 3 to P16 (MC1) 

on the 24-pin connector and injectors 4 and 5 to P17 (MC2) on the 24-pin connector. 

These injectors can be trigged in batch fire mode after a certain rpm / load or blend function. 

More information on staged injection can be found at section 7.2.3 in the MS3-Pro manual. 
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5.10 FLEX FUEL 
The ECU contains a dedicated flex fuel input for the GM Flex Fuel Sensor (AC DELCO 13577429). The 

output from this sensor provides ethanol content and fuel temperature. The output can be run to P18 

(FLEXFUEL) on the 24-pin connector. Also, any other frequency-based sensor can be run to this pin. 

Please see section 7.2.4 of the MS3-Pro manual for more information. 

 

5.11 WATER METH INJECTION 
The ECU supports water meth injection. This includes driving an external solenoid via P13 (VVT1), P14 

(VVT2), P16 (MC1) or P17 (MC2) on the 24-pin connector. It also supports low fluid level sensing via one 

of the 5V digital inputs P7 (DI2(5)) and P8 (DI3(5)) on the 12-pin connector. 

Please see section 7.8.16 of the MS3-Pro manual for more information. 
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5.12 REAR WHEEL SPEED INPUT 
A rear wheel speed input can be configured for use with traction control techniques. MS3-Pro expects a 

5V or 12V square wave however the ABS sensors are VR sensors (AC sine wave). Therefore, you must 

use a VR conditioner such as a MAX9924 to condition the VR signal to a square wave signal and then 

input that into P20 (SPEED2) on the 24-pin connector. Also, any other frequency-based sensor can be 

run to this pin. 

More information on vehicle speed sensors can be found at section 7.8.1 in the MS3-Pro manual. 

 

5.13 KNOCK SENSOR OUTPUT 
If one wishes to listen to the knock sensors through head phones, they can connect P11 (KNK1) on the 

12-pin connector to the left side of a headphone jack and P12 (KNK2) on the 12-pin connector to the 

right side of the headphone jack and P2 (SGND) on the 24-pin connector to the ground of the jack. This 

can be connected to the microphone input on a laptop and then listened to and recorded in a program 

such as Audacity. 

 

5.14 EXTERNAL CAN DEVICES 
External CANBUS devices can be hooked up to the system by connecting the CAN-L and CAN-H of the 

device to the ECU. On the right connector P21 on the 24-pin connector is CAN-L and P22 on the 24-pin 

connector is CAN-H. P24 (PGND) on the 24-pin connector can be used to connect the grounds of the 

devices. 

See section 7.10 in the MS3-Pro manual for further configuration. 
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6 ADDITIONAL INFORMATION 

6.1 EXTERNAL CONNECTOR PART NUMBERS 
• 12 pin connector – Molex 39-01-2120 

• 24 pin connector – Molex 39-01-2240 

• Pre-crimped leads – Molex 79758-0001 

6.2 PINOUT TABLES 

6.2.1 VolSquirt to MegaSquirt Pin Table 

VolSquirt Pin MegaSquirt Pin 
AIN2 Analog In 2 

AIN3 Analog In 3 

EADC0 CAN ADC01 

EADC1 CAN ADC02 

EADC2 CAN ADC03 

EADC3 CAN ADC04 

EADC4 CAN ADC05 

EADC5 CAN ADC06 

EADC6 CAN ADC07 

EADC7 CAN ADC08 

VVT1 High Current Out 1 

VVT2 High Current Out 2 

VVTCMP Digital Frequency In 1 

MC1 Injector I 

MC2 Injector J 

FLEXFUEL Digital Switched In 1 

IGN7 Spark G 

SPEED2 Digital Frequency In 3 

DI2(5) Digital Switched In 2 

DI3(5) Digital Switched In 3 

 


